mhiro

Junior Member
7+ Year Member
15+ Year Member
Jul 11, 2002
15
0
42
Missoula, Montana
Status
Soooo....

My application officially went "Active" on July 2nd when my last transcript was received. Now it's been 4 weeks (July 28th) and still no change in status. No "Processed" message or "Transmitted" message on my AMCAS page. Nothing...


Anyone know what the frickin' deal is? I know that AMCAS says it takes 4-6 weeks for processing but now that I am officially within that range, do I start calling them and getting more insistant. Any advice on this at all guys??

Is anyone else still waiting who submitted around that time???

meh :mad: :mad: :mad:
 

Tweetie_bird

7+ Year Member
15+ Year Member
Nov 20, 2001
2,193
2
41
Visit site
Status
call em up and find out what the deal is! I was active for a whole two weeks even though all my stuff was in, and called em up to ask them what was up with that. . . .this really nice guy helped me and quite to my surprize, about a week after that, I got verified.

I went active 7/7 and got verified . . . like 3 weeks after that. Forgot the date. Anyway, it turns out that even though it "might" look like there is no activity in your file, there are things happening behind the scenes. Most of my transmissions were a week AFTER I submitted. I just found out about it much much later. :(

So hopefully, if you have been receiving secondaries from schools, that's a sign that things are happening behind the scenes. Otherwise, I'd just call em and nag. :clap:
 
About the Ads