Forum Members Site Updates Coming Next Week!

alexj-12

Full Member
Staff member
Administrator
Volunteer Staff
Verified Expert
  • Apr 16, 2021
    140
    80
      Hey everybody!

      Just wanted to send out a quick message on all of the community updates that are coming up soon.

      September 27th
      We've developed a system to make it easier to find the content you're looking for through "feeds" that's being added to the site on September 27th!
      • Create many types of content through the "create" button at the top of the page.
      • Set your favorite feed as your default feed so that it will show up first when you log into the community.
      • Select from a large number of filter options to only see the content you want to see (these filters can be saved so that you only need to set them once)
      • A dedicated questions feed to help any and all questions get answered.
      • Upvoting! You now have the ability to upvote as well as react to any content that you like.

      Screen Shot 2021-09-20 at 11.13.57 AM.png
      Screen Shot 2021-09-20 at 11.18.16 AM.png

      Screen Shot 2021-09-20 at 11.18.35 AM.png


      September 29th
      The site will be down starting at 8am CT for a site upgrade. The upgrade should take approximately 2 hours and is just meant to keep the site up to date and running smoothly!

      October 1st
      User upgrades and Achievements are coming October 1st! As I mentioned before here, we're rolling out some user upgrades and achievements. Just as a reminder, you're not required to get a user upgrade and can continue to use the site for free, but your support does help us keep the site going!

      We're also adding an achievements system, which is a great way to reward you all for all of your successes and an easy way for you guys to track your progress.

      Let us know if you have any questions about these changes!
       
      Last edited by a moderator:
      About the Ads

      alexj-12

      Full Member
      Staff member
      Administrator
      Volunteer Staff
      Verified Expert
    • Apr 16, 2021
      140
      80
        Yes, we're always looking for feedback on new systems we're implementing, so if there's a feature that enough people don't like we'll absolutely reconsider :) If you could provide additional information about why you're against the upvoting system that would be helpful!
         

        jhmmd

        supernatural
      • Apr 28, 2020
        2,082
        1,590
        desert highway
          Yes, we're always looking for feedback on new systems we're implementing, so if there's a feature that enough people don't like we'll absolutely reconsider :) If you could provide additional information about why you're against the upvoting system that would be helpful!
          Well I don't mean to complain but my reasoning is twofold:
          1) Upvoting is a popular feature on Reddit and Reddit is cluttered and full of uneducated opinions. I don't want SDN to be like Reddit! :lol:
          2) The structure of the forums is such that it enables old threads (esp. flame threads that need to be closed) to die in a timely manner, and encourages people to read through all the posts in the forum before deciding which threads to reply to. Upvoting encourages people to just blindly flock to whatever threads are most popular.

          I know that I may have not stated this properly, but what is popular is not always right, and what is right is not always popular.

          The feed feature seems cool as long as it is optional

          Some ideas:
          1) Permanent time stamps on posts
          2) More customization options
          3) Reviews and recommendations forum

          Thanks for listening! :)
           
          • Like
          Reactions: 3 users

          Crayola227

          Contrary to rumor I am not Jesus
          7+ Year Member
          Oct 22, 2013
          22,305
          26,478
          All of Time & Space
            I agree that on SDN given the nature of debates, it's better that a thread and content is presented chronologically than by popularity.

            Take pre-allo or allo for example. Frequently the least popular posts may be hearing something someone doesn't want to hear from a physician or adcom about say admissions. The most popular could be by people who have no real experience with admissions.

            Same thing with threads. Sometimes it's the most contentious threads that make the most angry that is most useful.
             
            • Like
            Reactions: 2 users

            alexj-12

            Full Member
            Staff member
            Administrator
            Volunteer Staff
            Verified Expert
          • Apr 16, 2021
            140
            80
              Thanks for the feedback!

              The upvoting system is not entirely like Reddit's upvoting system in that the content that is most upvoted won't be moved higher up than content that has less upvotes. Think of it as similar to reactions. It's just another way to tell people that you like their content, but it's not moving that content to a place of more prominence, it's simply receiving an extra score.

              Upvoted posts within a thread wouldn't be moved to higher within the thread and upvoted threads within a feed wouldn't be moved up to higher within the feed unless you used a filter to view a feed in that way.

              So the structure of content will stay the same, having the upvoting system included is just another way for people to say that they like someone's content.

              Let me know if that helps explain things better!

              And thanks for the extra ideas @jhmmd I'll discuss those with the team :)
               
              • Like
              • Love
              Reactions: 1 users

              alexj-12

              Full Member
              Staff member
              Administrator
              Volunteer Staff
              Verified Expert
            • Apr 16, 2021
              140
              80
                Hey everybody, we just finished our site upgrade! This was a small update primarily meant to keep the site using the newest software and running smoothly, so there shouldn't be any major adjustments.

                Please let me know if you see any issues or need any help!
                 

                alexj-12

                Full Member
                Staff member
                Administrator
                Volunteer Staff
                Verified Expert
              • Apr 16, 2021
                140
                80
                  Hi everyone! Just to update, new achievements and user upgrades are now live on the site. You can check out achievements here and user upgrades here. I do want to remind you though, the user upgrades are not required to use the site, but you support does help us keep the site in good shape!

                  If you have any questions let me know :)
                   
                  • Like
                  Reactions: 1 user
                  About the Ads

                  silverrains

                  Endlessly Drifting
                  5+ Year Member
                  Gold Member
                  Mar 7, 2015
                  2,241
                  5,308
                  29
                  Missouri, US
                    I've noticed a couple of weird things since the updates.

                    1) On all of the newer styles (AC Default, AC Dark, Blue Thunder), Gold Member postbits have a yellow-gold background color; on the Basic styles, they do not. I understand that this may simply be due to those older styles not supporting the feature, but I wanted to point it out just in case it was intended to apply across all styles and/or was an oversight.

                    postbit_default.png

                    postbit_basic.png


                    2) When typing a query into the search box in the top right corner of the layout while partway down the page, it causes the screen to scroll up a small amount with each additional character typed. It also scrolls when using the backspace key or highlighting the typed text. This occurs on all styles for me except for Basic and Basic Dark. I'm running Firefox 89.0.2 on Linux Mint 20.2 (desktop) and Firefox 92.1.1 on Android 11 (mobile); this bug happens on both. Here is a video of this behavior.

                    I'll try to see if I can replicate it in other OS + browser setups in a little bit.

                    EDIT 1: Just tested it in Chrome 94 on Android 11---did the same thing. I also tested it on a few other forums I go to that also use the new version of XenForo and was not able to replicate it, so it seems to be SDN-specific.

                    EDIT 2: Tested it in both Edge 94 and Chrome 94 on Windows 10 while at work and was able to replicate it again in both browsers.
                     
                    Last edited:

                    alexj-12

                    Full Member
                    Staff member
                    Administrator
                    Volunteer Staff
                    Verified Expert
                  • Apr 16, 2021
                    140
                    80
                      I've noticed a couple of weird things since the updates.

                      1) On all of the newer styles (AC Default, AC Dark, Blue Thunder), Gold Member postbits have a yellow-gold background color; on the Basic styles, they do not. I understand that this may simply be due to those older styles not supporting the feature, but I wanted to point it out just in case it was intended to apply across all styles and/or was an oversight.

                      View attachment 344046
                      View attachment 344045

                      2) When typing a query into the search box in the top right corner of the layout while partway down the page, it causes the screen to scroll up a small amount with each additional character typed. It also scrolls when using the backspace key or highlighting the typed text. This occurs on all styles for me except for Basic and Basic Dark. I'm running Firefox 89.0.2 on Linux Mint 20.2 (desktop) and Firefox 92.1.1 on Android 11 (mobile); this bug happens on both. Here is a video of this behavior.

                      I'll try to see if I can replicate it in other OS + browser setups in a little bit.

                      EDIT 1: Just tested it in Chrome 94 on Android 11---did the same thing. I also tested it on a few other forums I go to that also use the new version of XenForo and was not able to replicate it, so it seems to be SDN-specific.

                      EDIT 2: Tested it in both Edge 94 and Chrome 94 on Windows 10 while at work and was able to replicate it again in both browsers.
                      Hey there! Yes, this is due to the basic styles being legacy styles, so the post bit coloring has only been added to the newer and up to date styles.

                      As for the issue with search, I'll take a look and see if I can determined what is causing this!
                       
                      • Like
                      Reactions: 1 users

                      alexj-12

                      Full Member
                      Staff member
                      Administrator
                      Volunteer Staff
                      Verified Expert
                    • Apr 16, 2021
                      140
                      80
                        @alexj-12 is it possible to make achievements and XP more current/updated with the account pls? Especially for those 100 post, 1000 post etc achievements
                        The achievements and XP are currently in the process of being applied to accounts retroactively. So all of the achievements that you earned before the achievements system was in place will be applied to your account, it just takes a bit of time for the system to go through all of the users and all of the content on the site :)
                         

                        alexj-12

                        Full Member
                        Staff member
                        Administrator
                        Volunteer Staff
                        Verified Expert
                      • Apr 16, 2021
                        140
                        80
                          I've noticed a couple of weird things since the updates.

                          1) On all of the newer styles (AC Default, AC Dark, Blue Thunder), Gold Member postbits have a yellow-gold background color; on the Basic styles, they do not. I understand that this may simply be due to those older styles not supporting the feature, but I wanted to point it out just in case it was intended to apply across all styles and/or was an oversight.

                          View attachment 344046
                          View attachment 344045

                          2) When typing a query into the search box in the top right corner of the layout while partway down the page, it causes the screen to scroll up a small amount with each additional character typed. It also scrolls when using the backspace key or highlighting the typed text. This occurs on all styles for me except for Basic and Basic Dark. I'm running Firefox 89.0.2 on Linux Mint 20.2 (desktop) and Firefox 92.1.1 on Android 11 (mobile); this bug happens on both. Here is a video of this behavior.

                          I'll try to see if I can replicate it in other OS + browser setups in a little bit.

                          EDIT 1: Just tested it in Chrome 94 on Android 11---did the same thing. I also tested it on a few other forums I go to that also use the new version of XenForo and was not able to replicate it, so it seems to be SDN-specific.

                          EDIT 2: Tested it in both Edge 94 and Chrome 94 on Windows 10 while at work and was able to replicate it again in both browsers.
                          Could you tell me if you're still seeing this issue with search? We attempted to replicate using the browsers you mentioned and aren't able to see the issue on our end
                           
                          • Like
                          Reactions: 1 user

                          silverrains

                          Endlessly Drifting
                          5+ Year Member
                          Gold Member
                          Mar 7, 2015
                          2,241
                          5,308
                          29
                          Missouri, US
                            Could you tell me if you're still seeing this issue with search? We attempted to replicate using the browsers you mentioned and aren't able to see the issue on our end
                            Yes, I'm still seeing this behavior on all of the non-legacy styles. Just because I don't know that I made it very clear in my original post---and in case it helps at all---it only occurs when I am partway down the page. Also, I generally use Basic style, so it's not an issue for me personally. Still, I could see how it might be frustrating for users of the newer styles who are trying to use the search function, particularly on mobile, which is why I wanted to mention it. Would be interesting to hear if it's affecting anyone else.

                            Oddly, I just tested it again using the default AC style in an older version of Firefox (87.0, on a brand new installation of Ubuntu 21.04) and actually wasn't able to reproduce it there, so... *shrugs*.
                             
                            Last edited:

                            alexj-12

                            Full Member
                            Staff member
                            Administrator
                            Volunteer Staff
                            Verified Expert
                          • Apr 16, 2021
                            140
                            80
                              Yes, I'm still seeing this behavior on all of the non-legacy styles. Just because I don't know that I made it very clear in my original post---and in case it helps at all---it only occurs when I am partway down the page. Also, I generally use Basic style, so it's not an issue for me personally. Still, I could see how it might be frustrating for users of the newer styles who are trying to use the search function, particularly on mobile, which is why I wanted to mention it. Would be interesting to hear if it's affecting anyone else.

                              Oddly, I just tested it again using the default AC style in an older version of Firefox (87.0, on a brand new installation of Ubuntu 21.04) and actually wasn't able to reproduce it there, so... *shrugs*.
                              Okay got it! We'll keep looking to see if we can replicate this issue. Could you provide links to any specific pages where this was happening?
                               
                              • Like
                              Reactions: 1 user

                              silverrains

                              Endlessly Drifting
                              5+ Year Member
                              Gold Member
                              Mar 7, 2015
                              2,241
                              5,308
                              29
                              Missouri, US
                                Okay got it! We'll keep looking to see if we can replicate this issue. Could you provide links to any specific pages where this was happening?
                                It seems to be occurring site-wide for me, but here are a selection of URLs for pages that I've explicitly tested and replicated it on:


                                It's also happens in my PM inbox and threads, too, so... pretty much everywhere on the forums, haha.
                                 

                                alexj-12

                                Full Member
                                Staff member
                                Administrator
                                Volunteer Staff
                                Verified Expert
                              • Apr 16, 2021
                                140
                                80
                                  It seems to be occurring site-wide for me, but here are a selection of URLs for pages that I've explicitly tested and replicated it on:


                                  It's also happens in my PM inbox and threads, too, so... pretty much everywhere on the forums, haha.
                                  Thanks for taking the time to get these links for me! We'll take a look and see if we can replicate and I'll let you know if we need any extra info :)
                                   
                                  • Like
                                  Reactions: 1 user

                                  supershorty

                                  still not a wolf
                                  7+ Year Member
                                  Silver Member
                                  Gold Member
                                  Jan 14, 2013
                                  5,263
                                  13,750
                                  1. Veterinary Student
                                    @alexj-12 Is there any way that we can resurrect the Threadloom search function? The new search is much more limited and not as good at catching and ordering all the relevant posts. Really missing Threadloom.

                                    It was working well for a little while after I'd flagged the issue with it, but now it's disappeared completely.
                                     

                                    alexj-12

                                    Full Member
                                    Staff member
                                    Administrator
                                    Volunteer Staff
                                    Verified Expert
                                  • Apr 16, 2021
                                    140
                                    80
                                      @alexj-12 Is there any way that we can resurrect the Threadloom search function? The new search is much more limited and not as good at catching and ordering all the relevant posts. Really missing Threadloom.

                                      It was working well for a little while after I'd flagged the issue with it, but now it's disappeared completely.
                                      I'll look into this to see what might be the issue here. Thanks for your patience!
                                       
                                      • Care
                                      Reactions: 1 user

                                      supershorty

                                      still not a wolf
                                      7+ Year Member
                                      Silver Member
                                      Gold Member
                                      Jan 14, 2013
                                      5,263
                                      13,750
                                      1. Veterinary Student
                                        I just got a notification that I "reached level 25". However, apparently, I have already been there at least since October 4. If it is just telling me now, that's quite a lag. Snail mail would have beaten it.
                                        I reached level 15 about a week ago, but then just reached level 8 yesterday :laugh:
                                         
                                        • Haha
                                        Reactions: 1 user

                                        alexj-12

                                        Full Member
                                        Staff member
                                        Administrator
                                        Volunteer Staff
                                        Verified Expert
                                      • Apr 16, 2021
                                        140
                                        80
                                          I just got a notification that I "reached level 25". However, apparently, I have already been there at least since October 4. If it is just telling me now, that's quite a lag. Snail mail would have beaten it.

                                          I reached level 15 about a week ago, but then just reached level 8 yesterday :laugh:
                                          Thank you both for letting me know about this! I'll pass this info to our add-on developers to get out a fix
                                           
                                          About the Ads

                                          Your message may be considered spam for the following reasons:

                                          1. Your new thread title is very short, and likely is unhelpful.
                                          2. Your reply is very short and likely does not add anything to the thread.
                                          3. Your reply is very long and likely does not add anything to the thread.
                                          4. It is very likely that it does not need any further discussion and thus bumping it serves no purpose.
                                          5. Your message is mostly quotes or spoilers.
                                          6. Your reply has occurred very quickly after a previous reply and likely does not add anything to the thread.
                                          7. This thread is locked.

                                          Common Requests

                                          Enter a Help Desk Request
                                          Make a Suggestion

                                          Doctor Verification
                                          Faculty Verification
                                          Administration Verification
                                          Classifieds Verification
                                          Uniformed Services Free Upgrade
                                          Delete Posts and Threads
                                          Delete Account